Information

Name :  XSS Vulnerabilities in eFront
Software :  eFront 3.6.10 build 11944 and possibly below.
Vendor Homepage :  http://efrontlearning.net/
Vulnerability Type :  Cross-Site Scripting
Severity :  High
Researcher :  Canberk Bolat
Advisory Reference :  NS-11-007

Description

eFront is a modern learning system, bundled with key enterprise functionality ranging from skill-gap analysis and branch management to tailor-made reports. We have worked with hundreds of organizations to shape a product that is easy-to-use, feature rich and especially suited for medium enterprises.

Details

eFront is affected by XSS vulnerabilities in version 3.6.10 build 11944.
Example PoC urls are as follows :


You can read the full article about Cross-Site Scripting vulnerabilities from here : Cross-site Scripting

Solution

Upgrade to the latest eFront version (3.6.10 build 12151).

Credits

It has been discovered on testing of Netsparker, Web Application Security Scanner - /netsparker/.

References

Vendor Url : http://forum.efrontlearning.net/viewtopic.php?f=15&t=3501

MSL Advisory Link :/XSS-Vulnerability-in-eFront/

Netsparker Advisories : /netsparker-advisories/

About Netsparker

Netsparker® can find and report security issues such as SQL Injection and Cross-site Scripting (XSS) in all web applications regardless of the platform and the technology they are built on. Netsparker's unique detection and exploitation techniques allows it to be dead accurate in reporting hence it's the first and the only False Positive Free web application security scanner.