Download Netsparker
Pricing
Blog
Contact
Netsparker

Bloofox CMS Affected by Multiple XSS Vulnerabilities Identified with Netsparker

Information
--------------------
Name :  XSS Vulnerabilities in bloofoxCMS
Software :  bloofoxCMS 0.3.5 and possibly below.
Vendor Homepage :  http://www.bloofox.com
Vulnerability Type :  Cross-Site Scripting
Severity :  Critical
Researcher :  Canberk Bolat
Advisory Reference :  NS-12-015

Description
--------------------
bloofoxCMS is a free open source content management system (CMS). bloofoxCMS is a small and easy to use CMS. It enables you to manage websites and intranet sites on a very simple way. It is slim but also flexible.

Details
--------------------
bloofoxCMS is affected by XSS vulnerabilities in version 0.3.5

  • http://example.com/index.php?'"--><script>alert(0x0004B3)</script>
  • http://example.com/index.php?search='"--><script>alert(0x0004B3)</script>

You can read the full article about Cross-Site Scripting from here:

Solution
--------------------
The vendor fixed this vulnerability in the new version. Please see the references.

Advisory Timeline
--------------------
23/01/2011 - First contact
25/02/2012 - Vulnerability Fixed
31/10/2012 - Advisory released

Credits
--------------------
It has been discovered on testing of Netsparker, Web Application Security Scanner - /netsparker/.

References
--------------------

About Netsparker
--------------------
Netsparker® can find and report security issues such as SQL Injection and Cross-site Scripting (XSS) in all web applications regardless of the platform and the technology they are built on. Netsparker's unique detection and exploitation techniques allows it to be dead accurate in reporting hence it's the first and the only False Positive Free web application security scanner.

Netsparker Wep Application Security Scanner Find and Exploit vulnerabilities in Web Applications with Netsparker

Request Demo version of Netsparker ProfessionalorBuy Netsparker Professional