Information
--------------------
Name : LFI & XSS Vulnerability in Codiad
Software : Codiad 2.3.6 and possibly below.
Vendor Homepage : http://codiad.com/
Vulnerability Type : Cross-site Scripting and Local File Inclusion
Severity : Critical
Researcher : Omar Kurt
Advisory Reference : NS-14-029

Description
--------------------
Codiad is a web-based IDE framework with a small footprint and minimal requirements. The system is still early in development, and while it has been proven extremely stable please be sure have a backup system if you use it in any production work.

Details
--------------------
Codiad is affected by XSS & LFI vulnerability 2.3.6.

Codiad PoC urls are as follows :

You can read the full article about XSS and LFI vulnerabilities from here :


Solution
--------------------
-

Advisory Timeline
--------------------
25/06/2014 - First Contact
07/06/2014 - Second Contact
20/08/2014 - Advisory released

Credits
--------------------
It has been discovered on testing of Netsparker Web Application Security Scanner.


About Netsparker
--------------------
Netsparker® can find and report security issues such as SQL Injection and Cross-site Scripting (XSS) in all web applications regardless of the platform and the technology they are built on. Netsparker's unique detection and exploitation techniques allows it to be dead accurate in reporting hence it's the first and the only False Positive Free web application security scanner.