Information
--------------------
Name : XSS Vulnerabilities in FishEye
Software : FishEye v3.3.3 and possibly below.
Vendor Homepage : https://www.atlassian.com/software/fisheye/overview
Vulnerability Type : Cross-site Scripting
Severity : Critical
Researcher : Omar Kurt
Advisory Reference : NS-14-018

Description
--------------------
FishEye provides a read-only window into your Subversion, Perforce, CVS, Git, and Mercurial repositories, all in one place. Keep a pulse on everything about your code: Visualize and report on activity, integrate source with JIRA issues, and search for commits, files, revisions, or people..

Details
--------------------
FishEye is affected by XSS vulnerabilities in version 3.3.3.

Example PoC urls are as follows :

You can read the full article about Cross-site Scripting vulnerabilities from here :


Solution
--------------------
http://www.atlassian.com/software/fisheye/downloads/binary/fisheye-3.4.0.zip

Advisory Timeline
--------------------
08/04/2014 - First Contact
08/04/2014 - Second Contact
15/04/2014 - Vendor fixed vulnerability
23/04/2014 - Advisory Released

Credits
--------------------
It has been discovered on testing of Netsparker Web Application Security Scanner.

About Netsparker
--------------------
Netsparker® can find and report security issues such as SQL Injection and Cross-site Scripting (XSS) in all web applications regardless of the platform and the technology they are built on. Netsparker's unique detection and exploitation techniques allows it to be dead accurate in reporting hence it's the first and the only False Positive Free web application security scanner.